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Pascal-W Limitations

Pascal-W is not a full implementation of standard Pascal in some areas.    
However, it contains many enhancements to standard Pascal as well.

Standard Pascal features not in Pascal-W
- enumerated types
- set types
- pointer types
- the WITH statement for use in records
- variant records

Pascal-W also has these size limitations
- 64K of code; since this is of a PCODE type nature this would be a very large program
- 64K of constant strings; the text enclosed in single quotes in your program
- 32K of variables; this is the size of the storage, not the number of variables you can have



Pascal-W Capabilities

Pascal-W is also extended in many areas beyond standard Pascal.

Pascal-W supports an array of chars starting with a zero index as a string.    This 
allows string comparisions, string assignments, strings to be used in the formal parameter
list for functions and procedures, and read/write capablities for strings.    However, 
Pascal-W does not allow the plus(+) operator to be used on strings.

Pascal-W supports many intrinsic functions and procedures not found in standard 
Pascal, these functions and procedures allow Pascal-W to better interact with the 
Windows environment.

Pascal-W is one of the very few Windows programs that performs pre-emptive 
multitasking.    And it may very well be the only Windows programming environment 
where it always allows other programs to run.    For example, when doing heavy 
computations (like a iterative loop), Pascal-W still allows you to click on other windows or 
do something else during the computation.

Pascal-W supports multi-threading within itself.    It provides support for co-routines 
and semaphores for synchronization.    You may have up to four co-routines running 
simultaneously.    The enable and disable routines can be used to enclose a critical 
section and prevent a co-routine switch.    The signal and wait routines are used to 
release and hold on a semaphore.    The SMOKER.PAS program demonstrates their 
usage.

Pascal-W supports inclusion of other Pascal source files through the use of $I from 
within a comment statement.    This allows you to break up your program into multiple 
source files.



More information about Pascal-W
The Pascal-W program was written by Rick Wirch with some parts by Chris Davis.    

Some of the documentation (the well written parts) were written by Pam Hudson.    Bob 
Norton also provided much inspiration and help (as well as the idea to release this to the 
public).

Bob Norton can be reached on Compu-Serve.    CIS ID [70017,1765]

Rick Wirch can be reached by the powerful US mail system
Rick Wirch
4802 Shore Acres Rd
Monona, WI 53716



An example of $I usage
Program Multi( input, output );

{$I Another.PAS}

Begin
    Write( Variable declared in Another.PAS );
End.



Pascal-W Keys

Use the following keys in Pascal-W:

Key(s) Function

Ctrl+Insert Copies text into the Clipboard.

Ctrl+Delete Cuts text and places it into the Clipboard.

Delete Deletes text.

Shift+Insert Pastes the contents of the Clipboard into the file.

F1 Displays help for the Pascal-W application.

F3 Locates the next occurrence of specified text without opening the Find box.

F4 Changes the next occurrence of specified text to new text without opening the Find 
box.

F9 Searches for errors in the program file.



Pascal-W Menu Commands
To get help with a particular menu command, choose the appropriate menu.    

File Menu Commands
New
Open
Save
Save As
Print
Exit

Edit Menu Commands
Undo
Cut
Copy
Paste
Delete
Select All

Search Menu Commands
Find
Find Next
Change
Change Next
Program Errors

Window Menu Commands
Tile
Cascade
Arrange Icons
Close All

Pascal Menu Commands
Run
Stop
1/4 Speed
1/2 Speed
3/4 Speed
4/4 Speed



File Menu Commands
These commands enable you to create, open, save and print files or quit the Pascal-W application.

New
Displays a blank work area so you can create a new program file.

Related Topics
Creating a file

Open
Lets you select a file from the computer's fixed disk or from a floppy disk.    It then displays the file's 
contents in the Pascal-W work area.    You can open and modify multiple files while using the Pascal-W 
application.

Related Topics
Opening a file

Save
Saves the file's contents to the name indicated on the title bar.

Related Topics
Saving a file

Save As
Lets you save the file's contents to the same name or to a different name.

Related Topics
Saving a file

Print
Sends the file's contents to the printer.

Related Topics
Printing a file

Exit
Closes any open files and quits the Pascal-W application.    If any of the open files have not been saved, 
you can save each file before exiting.



Edit Menu Commands
These commands enable you modify a file.

Undo
Cancels the last change you made to the file.    

Related Topics
Undoing your last action

Cut
Deletes the selected text and copies it into the Clipboard.    

Use Paste to insert the text in another location in the same file or into a different file.

Related Topics
Copying, deleting, and moving text
Selecting text

Copy
Copies the selected text into the Clipboard.

Use Paste to insert the text in another location in the same file or into a different file.

Related Topics
Copying, deleting, and moving text
Selecting text

Paste
Inserts a copy of the text in the Clipboard at the insertion point or replaces the selected text.

Related Topics
Copying, deleting, and moving text
Selecting text

Delete
Deletes the selected text; the text is not copied to the Clipboard.

Related Topics
Copying, deleting, and moving text
Selecting text

Select All
Highlights all the text in the file.

Related Topics
Copying, deleting, and moving text
Selecting text





Search Menu Commands
These commands enable you to locate and modify text in a file.

Find
Searches the file for the specified text.

Related Topics
Finding text
Replacing text

Find Next
Searches the file for the next occurrence of the specified text.

Related Topics
Finding text
Replacing text

Change
Replaces the specified text with new text.

Related Topics
Finding text
Replacing text

Change Next
Replaces the next occurrence of the specified text with new text.

Related Topics
Finding text
Replacing text

Program Errors
Searches for errors in the program.

Related Topics
Searching for programming errors



Window Menu Commands
These commands enable you to modify the appearance of the Pascal-W application window.    

Tile
Sizes the open file windows so they fit within the Pascal-W application window.

Related Topics
Arranging file windows

Cascade
Arranges the open file windows so you can see each one's title bar.

Related Topics
Arranging file windows

Arrange Icons
Aligns the icons for any open file windows along the bottom of the Pascal-W application window.

Related Topics
Arranging icons

Close All
Close all of the files that are currently open.    This command doesn't close the Pascal-W application.

Related Topics
Closing all open windows



Pascal Menu Commands
These commands enable you to start and stop a run.    Plus you can select the speed at which a program 
should run (1/4 is the slowest speed and 4/4 is the fastest speed).





Pascal-W Procedures

For step-by-step instructions, select one of the following topics.

Arranging icons
Arranging file windows
Closing all open windows
Copying, deleting, and moving text
Creating a file
Finding text
Opening a file
Printing a file
Quitting
Replacing text
Saving a file
Searching for programming errors
Selecting text
Undoing your last action



Arranging icons
The Pascal-W application can arrange file icons for you, or you can arrange them yourself.    

To arrange icons automatically:

* Choose Arrange Icons from the Window menu.

The application aligns the icons for any open file windows along the bottom of the Pascal-W 
application window.

To arrange icons manually:

* Drag each icon to its new location.



Arranging file windows

Using the File and Cascade commands, you can arrange the open file windows so that you can see part 
of each window.    

To arrange all of the open file windows:

* Choose File or Cascade from the Window menu.

Tile sizes the open file windows so they fit within the Pascal-W application window.    None of the 
windows will overlap.

Cascade arranges the open file windows so you can see each one's title bar.



Closing all open windows
To close the window for all open files:

* Choose Close All from the Window menu.

If any of the file windows have not been saved, you can save the file before it closes.



Copying, deleting, and moving text
To copy text (and place it into the Clipboard):

Mouse 1 Select the text to be copied.
2 Choose Copy from the Edit menu.

Keyboard 1 Select the text to be copied.
2 While holding down the Ctrl key, press the Insert key.

To delete text (and not copy it into the Clipboard):

Mouse 1 Select the text to be deleted.
2 Choose Delete from the Edit menu.

Keyboard 1 Select the text to be deleted.
2 Press the Delete key.

To move text:

Mouse 1 Select the text to be moved.
2 Choose Cut from the Edit menu.    
3 Position the insertion point where you want to insert the text.

Or select the text you want to be replaced.
4 Choose Paste from the Edit menu.

Keyboard 1 Select the text to be moved.
2 While holding down the Ctrl key, press Delete.
3 Use the direction keys to move the insertion point where you want to insert the text.

Or select the text you want to be replaced.    
4 While holding down the Shift key, press Insert.



Creating a file
To begin work on a new file:

* Choose New from the File menu.

Related Topics
Opening a file



Finding text
To locate a word or text string in the file:

1 Position the insertion point where you want to start the search (usually at the beginning of the file).
2 Choose Find from the Search menu.
3 Type the text that you want to search for in the Find What text box.
4 Choose Find Next to begin the search.
5 Repeatedly choose Find Next to locate any other occurrences of the text.

To search without using the Find box:

1 Use the Find command, as described above, to find the first occurrence of the text.
2 Close the Find box.
3 Press F3.



Opening a file
To display the contents of a file:

1 Choose Open from the File menu.

2 Type the desired path and filename in the text box.

Or, select the name from the list box.    The list box displays the programs you have previously written 
and saved on your computer.    If necessary, use the scroll bar to display additional names.    To change
to the parent directory of the current directory, double-click on [..].    Double-click on [-A-] to change to 
the root directory of floppy drive A; other letters correspond to other available drives.

When the desired file name appears in the list box, click on its name.

3 Click on Open.

Related Topics
Creating a file



Printing a file
To print the contents of a file:

1 Choose Print from the File menu.



Quitting
To exit the Pascal-W application:

* Choose Exit from the File menu.

If any of the file windows have not been saved, you can save the file before it closes.



Replacing text
To find and replace a word or text string:

1 Position the insertion point where you want to start the search (usually at the beginning of the file).
2 Choose Find from the Search menu.
3 Type the text that you want to search for in the Find What text box.
4 Type the replacement text in the Change To text box.
5 Choose one of the command buttons.

Command Button Function

Find Next Searches for the word or text string.
Change, then Find Changes the currently selected search text with the replacement text, 

and then finds the next occurrence.
Change Changes the currently selected search text with the replacement text.
Change All Changes all occurrences of the search text with the replacement text.

To change without using the Find box:

1 Use the Find command, as described above, to find the first occurrence of the text.
2 Close the Find box.
3 Press F4 to change the next occurrence of the search text.



Saving a file
To save changes made to the current file:

1 Choose Save from the File menu.

To save a new file or the current file under a different name:

1 Choose Save As from the File menu.
2 Type a filename.
3 Choose Save.



Searching for programming errors
To search for errors in the program file:

* Choose the Program Errors command in the Search menu (or press the F9 key).



Selecting text
Selected text is white with a black background.    

To use mouse to select Do this

One or more words Point and click to position the insertion point to the left of the first 
character.    While pressing the left mouse button, move the mouse to
the right until the desired text is selected.

Several lines Position the mouse pointer along the left margin.    The pointer slants 
to the right.    While pressing the left mouse button, move the mouse 
up or down until the desired text is selected.

Entire file Choose Select All in the Edit menu.

To use keyboard to select Do this

One or more words Use the direction keys to position the insertion point to the left of the 
first character.    While pressing the Shift key, use the right direction 
key to select the desired text.

Several lines Use the direction keys to position the insertion point to the left of the 
first line to be selected.    The pointer slants to the right.    While 
pressing the Shift key, use the down direction key to select the 
desired text.

Entire file While pressing the Alt key, press E to open the Edit menu.    Then 
press S to choose the Select All command.



Undoing your last action
To cancel the last change you made to the file:

* Choose Undo from the Edit menu.



Pascal-W Intrinsic Commands

Intrinsic Functions
Intrinsic Procedures



Intrinsic Functions
These are the standard functions intrinsic to the language.
A    Pascal reference manual should provide the additional information you need.

abs( real expr ) : integer or real
arctan( real expr ) : real
chr( integer expr ) : char
cos( real expr ) : real
eof( file : text ) : boolean
eoln( file : text ) : boolean
exp( real expr ) : real
frac( real expr ) : real
keypressed : boolean
ln( real expr ) : real
length( string expr ) : integer
odd( integer expr ) : boolean
pos( substring, string : string ) : integer
pred( real expr ) : integer or real
random( integer expression ) : integer
readkey : char
round( real expr ) : integer
sin( real expr ) : real
succ( real expr ) : integer or real
sqr( real expr ) : integer or real
sqrt( real expr ) : integer or real
trunc( real expr ) : integer
upcase( char ) : char
ord( integer expr ) : integer



Intrinsic Procedures
These are the standard procedures intrinsic to the language.
A    Pascal reference manual should provide the additional information you need.

append( var file : text )
assign( var file : text, name : string )
chdir( dirname : string )
close( var file : text )
clrscr
dec( var x : integer )
delay( mS : integer )
disable
enable
erase( var file : text )
gettime( var hour, min, sec, hund : integer )
inc( var x : integer )
mkdir( dirname : string )
nosound
randomize
read( . . . )
rename( var file : text, newname : string )
reset( var file : text )
rewrite( var file : text )
rmdir( dirname : string )
signal( var i : integer )
sound( Hz : integer )
wait( var i : integer )
write( . . . )




